This site requires JavaScript to be enabled
IE BUMPER

Product
Version
IncidentLookup using list
Language
How can we help?

Solution Suggestions

Please enter your question to get suggestions.
  Help
IE BUMPER
Categories
Boolean Operators
OR or vertical bar symbol (|)
Finds a match if either the terms exist in a document (a union using sets).
AND
Finds a match if both terms exist in a document (an intersection of sets).
NOT, minus (-), or exclamation point (!)
Excludes documents that contain the term after NOT (a difference of sets).
Wildcards
Asterisk (*)
The asterisk symbol performs a multi character wildcard search.
Percent sign (%)
The percent sign performs a single character wildcard search.
Phrases
Quotation marks (")
Use quotation marks to search for an exact phrase with multiple terms.
For examples and more information look at our Knowledge Base: Advanced Search On The Support Portal

The maximum message size quota for incoming messages (65536) has been exceeded

This article describes a common error users may see with using ToscaCI and how to resolve the issue.


Situation

You are executing your TestCases via Continuous Integration (CI) and you suddenly see this error message followed by additional callstack information:

Error: 'The maximum message size quota for incoming messages (65536) has been exceeded'

Details

Users may run into this error if minimal changes have been made on the ToscaCI settings. Depending on the size and number of the tests run through ToscaCI, the amount of information that needs to be passed through the user's network connection between ToscaCI and the DEX Server will exceed the default number of bits used for communicating the results and this error message is thrown.

Solution

The solution to resolving and preventing this error is through modifying the ToscaCIClient.exe.config file that is typically found in either "%TRICENTIS_HOME%\ToscaCI\Client" for Tosca Versions prior to 12.2 or "%COMMANDER_HOME%\ToscaCI\Client" for Tosca Versions 12.2 and later.

Open the ToscaCIClient.exe.config and navigate to the section with the <basicHttpBinding> tag. That section should resemble something very close to the following:
 

<basicHttpBinding>
    <binding name="BasicHttpBinding_IRemoteExecutionService" closeTimeout="00:10:00" openTimeout="00:10:00" receiveTimeout="Infinite" sendTimeout="Infinite" allowCookies="false" bypassProxyOnLocal="false" hostNameComparisonMode="StrongWildcard" maxBufferPoolSize="524288" maxBufferSize="2147483647" maxReceivedMessageSize="2147483647" textEncoding="utf-8" transferMode="Buffered" useDefaultWebProxy="true" messageEncoding="Text">
        <readerQuotas maxDepth="32" maxStringContentLength="2147483647" maxArrayLength="16384" maxBytesPerRead="4096" maxNameTableCharCount="16384" />
        <security mode="None" />
    </binding>
    <binding name="BasicHttpBinding_IManagerService" />
</basicHttpBinding>


The 2nd binding, or the BasicHttpBinding_IManagerService, will need to be modified to resemble the exact format of the first binding so that section should now look like the following:
 

<basicHttpBinding>
    <binding name="BasicHttpBinding_IRemoteExecutionService" closeTimeout="00:10:00" openTimeout="00:10:00" receiveTimeout="Infinite" sendTimeout="Infinite" allowCookies="false" bypassProxyOnLocal="false" hostNameComparisonMode="StrongWildcard" maxBufferPoolSize="524288" maxBufferSize="2147483647" maxReceivedMessageSize="2147483647" textEncoding="utf-8" transferMode="Buffered" useDefaultWebProxy="true" messageEncoding="Text">
        <readerQuotas maxDepth="32" maxStringContentLength="2147483647" maxArrayLength="16384" maxBytesPerRead="4096" maxNameTableCharCount="16384" />
        <security mode="None" />
    </binding>
    <binding name="BasicHttpBinding_IManagerService" closeTimeout="00:10:00" openTimeout="00:10:00" receiveTimeout="Infinite" sendTimeout="Infinite" allowCookies="false" bypassProxyOnLocal="false" hostNameComparisonMode="StrongWildcard" maxBufferPoolSize="524288" maxBufferSize="2147483647" maxReceivedMessageSize="2147483647" textEncoding="utf-8" transferMode="Buffered" useDefaultWebProxy="true" messageEncoding="Text">
        <readerQuotas maxDepth="32" maxStringContentLength="2147483647" maxArrayLength="16384" maxBytesPerRead="4096" maxNameTableCharCount="16384" />
        <security mode="None" />
    </binding>
</basicHttpBinding>

Once you have made the changes, save the new configurations. The error should no longer be present in further executions with ToscaCI.

1 0

Thomas Ankerl

Created: 2018-05-09 13:59:50

Thanks, this solved our issue.

0 0

Rishi Harjani

Created: 2018-06-05 04:31:27

This actually does not solves the issue. we are still facing the same. Can you guys please tell us what is the root cause of this issue ?

Lee Lee

2018-06-25 20:13:39

Hello.  The above step 2 has an extra /> after the word <binding>/>.  Make sure you remove that /> from the binding of the IManagerService HTTPBinding setting.  Also, are you using HTTPS? If so, then you will need to update the security mode from "None" to "Transport" as you're traffic is not over HTTP.  Also, the updated settings control the message size, so if you are distributing large tests, the body of the message will exceed the default 65 KB, so adding the above entries, especially the maxReceivedMessageSize="2147483647"  setting, will allow for the max IIS message size of 2 GB.  Hope this helped.

1 0

Henk Schop

Created: 2018-08-27 09:59:03

I fixed it manuall in 11.1 and all worked fine. When I upgraded to 11.3 the issue came back. Shouldn't this be fixed in the base code, so that end users no longer have to fix this themselves?

 

Jan Mikes

2018-10-12 08:56:25

11.3 P2 still facing the issue.

Thomas Ankerl

2019-08-08 12:33:50

Tosca 12.1, and I still had to fix this manually. I also wonder why Tricentis cannot add this entry to their standard configuration.

0 0

Joost van Leeuwen

Created: 2018-12-18 09:08:51

The example has a typo:

 

</binding>/> 

 

Should be :

 

</binding>

0 0

Ramya Chandramohan

Created: 2019-09-04 07:48:50

We get the same issue in 12.2, when used the above solution the tests are still not getting triggered and the result file shows the tests are getting skipped.

Any inputs please

0 0

Ramya Chandramohan

Created: 2019-09-04 07:48:51

We get the same issue in 12.2, when used the above solution the tests are still not getting triggered and the result file shows the tests are getting skipped.

Any inputs please

IE BUMPER

Tosca is the perfect solution

Optimize - Manage - Automate

Download Trial